Tout savoir sur WordPress
Tutoriel WordPress

Utiliser la dernière version de jQuery dans WordPress

Cette astuce permet de remplacer la version de jQuery implantée par WordPress avec la dernière version existante de la librairie.

La librairie javascript utilisée par WordPress est jQuery. A ce sujet, il faut savoir que vous êtes dépendant de WordPress et de la version de jQuery installée. Il est fort probable que cette version ne soit pas la dernière en date de la librairie.

Par exemple, la version 3.2 de WordPress utilise la version 1.4 de jQuery et vous êtes bloqué avec cette version jusqu’à la prochaine mise à jour de WordPress.

Copier le code ci-dessous dans le fichier functions.php de votre thème pour bénéficier automatiquement de la dernière version de jQuery :

function insert_last_jquery() {
    if( !is_admin() ){
        wp_deregister_script('jquery');
        wp_register_script('jquery',"http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js", false, '');
        wp_enqueue_script('jquery');
   }
}
Cet article a été mis à jour il y a 2291 jours - Il n'est peut être plus à jour !

Article écrit par Jonathan B.

Jonathan est le co-fondateur de WP Media, startup connue pour être l’auteur de WP Rocket et Imagify. Il est aussi co-organisateur du WordCamp Lyon et Paris.

0 Commentaire

0abbe3b9055e2c72c7c07abc1a4f9c23bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb